Back to overview
Degraded

Upstream Provider Reporting Increased Errors and Latency

Nov 28 at 04:15pm GMT
Affected services
https://eu.engage.app/login
https://us.engage.app/login
https://au.engage.app/login

Resolved
Nov 28 at 05:10pm GMT

Twilio have confirmed they have resolved the issue and error rates have reduced. During this issue only a small percentage of requests were affected so most users would have been able to continue working unaffected.

Created
Nov 28 at 04:15pm GMT

Our Upstream Provider Twilio are reporting increased errors and latency with a subset of products we utilise. We have observed an increase in errors in the platform, but most requests remain successful. We will monitor the situation and provide further updates. For further information, please view Twilio's support page here: https://status.twilio.com/