Back to overview
Degraded

Task Routing is currently unavailable

Feb 17 at 12:24pm GMT
Affected services
https://eu.engage.app/login
https://us.engage.app/login
https://au.engage.app/login

Resolved
Feb 17 at 11:00pm GMT

We are seeing that the issue has been resolved and no more errors coming from our vendor

Updated
Feb 17 at 10:16pm GMT

The service is back up, with warnings of same intermittent issues. We are monitoring the situation to ensure no further escalation in issues and resolution.

Updated
Feb 17 at 06:11pm GMT

We are still awaiting updates on for the services we use from the vendor. The vendor has made a partial recovery.

Updated
Feb 17 at 04:03pm GMT

The vendor has identified the issues and is working to redeploy the services. Full service is expected to resume 17:00 UTC.

Created
Feb 17 at 12:24pm GMT

The task routing capability is down in the application due to issues with a 3rd party service. Our engineers are working to resolve the issue.

Our vendor has identified the issue and is expecting to resolve it and restore services by 17:00 UTC